Back to overview
Degraded

Service Degradation Notice

Nov 18 at 01:17pm CET
Affected services
Automations and Background Actions

Resolved
Nov 18 at 03:45pm CET

Everything is back to normal

Created
Nov 18 at 01:17pm CET

We are currently experiencing disruptions affecting our analytics and AI features due to issues with external service providers.

Current Status
SEO & GEO Analytics: Slowed down and partially degraded. This is caused by a network downtime at Cloudflare.

AI+ Features: Currently down (unavailable). This is due to API outages impacting both OpenAI and Anthropic.

We are monitoring the status of these external providers and expect services to return to normal as soon as their issues are resolved.

We apologize for the inconvenience.