Back to overview
Degraded

Google dropping num=100 parameter

Sep 14 at 03:01pm CEST
Affected services
Semji App

Resolved
Sep 23 at 09:30am CEST

We have deployed a patch that restores the previous behavior following Google’s recent change.
From now on, we are automatically scraping the first 10 pages of Google results. This ensures that we can continue to provide exhaustive and high-quality ranking data, including positions beyond the top 10.

👉 Your rankings outside of the first page are once again visible in Semji, with no loss in accuracy.

That said, this solution comes with a significant increase in infrastructure costs on our side. We will take time to carefully evaluate how best to absorb this impact while maintaining the level of service and data quality you expect from us.

Updated
Sep 18 at 03:22pm CEST

We have decided to implement automatic scraping of the first 10 Google result pages to simulate the former behavior of the num=100 parameter.

A patch will be deployed shortly to restore visibility on rankings beyond the 10th position. This ensures that our customers will not experience any long-term impact on data quality.

In parallel, we are closely monitoring the impact on third-party tools we rely on, to anticipate and mitigate any additional changes.

Created
Sep 14 at 03:01pm CEST

What Happened

Since September 14, 2025, Google has stopped supporting the parameter num=100.

Until now, this parameter allowed us to fetch the top 100 organic search results. Going forward, Google will only return the top 10 results per query.

This change has been confirmed by multiple reliable sources and affects our services temporarily.


Impact on Semji

Semji previously relied on this method to display rankings beyond the top 10. As a result, we are currently limited to recording the first 10 search results only.

This impacts the accuracy of the following features:

- My Position in Content Ideas

- Focus Keyword positions in Performance
- Ranking Keywords in Performance

- Focus Keyword positions in the Editor

- Ranking Keywords count in the Editor

- My Position & Position in Intel Hub


How You May Be Affected

If your content ranks outside the top 10 (e.g. in position 11 or beyond), Semji will now display it as “Not Ranking” or show no position value.


How Semji Will Resolve The Issue

We are actively investigating the best solutions to bring back the data for content ranking beyond the 10th position.